Start a new topic

Game Detection Not Working

Raptr Game Scanning isn't working for me. I reinstalled Windows 10 Pro and it worked prior to the clean install. I've tried disabling the Windows Firewall to see if it would download the correct game_detection.json files however it didn't. I also tried disabling my Avast Antivirus but had no luck there.

I don't know if this is the same problem I'm having.

When I go to Library and click the refresh installed game list button, it doesn't update it. It just pops open the scanning for new games window, the loading bars fill up instantly, then closes. The start scanning, downloading detection, downloading graphics, and whatever else is supposed to happen (can't read them all it happens so fast) happens in like 2-3 seconds then the window closes.

im having exactly the same problem. the game detection file wont download, tried reinstalling the program and deleting the cfg file several times, no fix yet

 Same here - I reinstalled desktop client and now I have nothing in Library and nothing detected, also manually adding is not working - game list is empty.

Same issue here :(


I have the same issue... I also tried to turn off the firewall and start Raptr in admin mode, but without success. I also tried to read the raptr.log in the appdata folder, and I found these lines:

WARNING: Dummy-27: unable to parse return code from getting gamedb: No JSON object could be decoded
WARNING: Dummy-27: BaseInstalledGamesManager.get_detection_db(): game db is missing the "info" field
DEBUG: Dummy-27: IGM::scan - finished calling get_detection_db()

So i think something wrong happens when the program tries to retrieve the "game_detection_pc.json" file. Maybe it's a server-side issue, I don't know :(

My problem is that it won't auto detect nor allow me to manually add because the files are missing.

same problem.


fixed as of now for me, game detection file download correctly upon scaning , now add fifa 17 and we are done :)

Same here - fixed :) Thank you for fixing this issue.


Login to post a comment