Start a new topic

Raptr Client Is Infuriating

 So I wanted to try out AMD GVR. I installed this ridiculous client, video recording works OK. Problem is this client overall is massively buggy. Every time I turn around I'm running into some nonsense issue.

First thing, I can't use the client period because when it's open it makes my alt key permanently pressed. So if I tap s it takes a screen shot even though the hotkey is alt s. I can't backstep in my games, it just takes screenshots over and over when I press s. I've restarted the client, restarted the PC, don't know what to do about this. If Raptr is open it thinks my alt key is depressed. I'm running a real standard setup here, Win 7 64 bit properly updated, FX 6300, R9 270X, Razer Black Widow Ultimate Stealth. Why in Odin's name would Raptr permanently depress my alt key? Unbinding things to alt in the options menu of the Raptr Gaming Evolved client settings doesn't help, it just makes the keys do nothing. Instead of taking a screen shot while pressing s in game it does nothing at all, I have to hold ALT s to step backwards. The problem completely goes away with Raptr closed and persists every single time if Raptr is open.

Second major issue is why, just why does Raptr's "optimization" garbage try to set all my games to 1280x720? Just why? It doesn't make any sense. I don't care if it thinks my PC is only capable of 720p, it's not even a supported resolution on my monitor. How can this program be so stupid as to screw with people's resolutions if it can't tell what resolutions your monitor supports? Literally the worst cancer software I've ever been cursed with installing.

6 people like this idea

Hey asgaeroth,

Let's look over these 2 different issues:

1) The Alt key being pressed in all the time...I've never heard of actually. So it would be interesting to figure out what is causing that. Do you have any kind of keyboard or mouse macro that might be utilizing the Alt key? Is Alt pressed constantly only in games, or in the desktop as well? Which games have you noticed this issue in? Additionally, can you open up Raptr and then send in logs right after it boots up?

To send to your log files:

1) Open the Raptr client

2) Right click on the Raptr icon in the system tray

3) Click on Help, then Feedback.

4) In the window that appears, check the box at the bottom (Send log file).

5) In the text box, please either describe the issue or paste the ticket number for your issue.

6) Hit send.

7) Post back here when you have sent your logs.

(Note: Make sure that you quit out of any game you are in before you send in your logs.) 

2) The optimization for games that optimize resolution will base it on your native resolution of your monitor. As such, the native resolution of your monitor is 1280x720 which is identified in your dxdiag. If the resolution change is not to your liking we recommend disabling the "Lower Resolution (if necessary)" or possibly adjusting the graphical settings of the game to what you deem appropriate. 

Let us know if you have any other questions or concerns. 

Dxdiag does not identify my monitor as 1280x720 native. I've used this monitor since Dec 2010 and Raptr is the first piece of software to ever identify that as a resolution I should be using and it set 40 or so games it detected to a resolution I can't display and clicking revert didn't switch them back so installing Raptr was a pretty significant headache for me. I still haven't completely solved it. I don't use any macro software, I don't have Synapse or any third party ones installed. I try to keep things light, I run MS Security Essentials, Steam, Origin, Adobe Flash, Silverlight, Open Hardware Monitor, MSI Afterburner, Firefox 36, 7 Zip, AMD Catalyst, and KeePass. That's the entire non game software library on my PC that Win 7 64 bit OEM doesn't install. Raptr is long uninstalled, and the alt depression was only while opening Guild Wars 2 with Raptr running. It was persistent through software and system resets.

Well if Raptr is uninstalled now, there really isn't much we can do to attempt to solve the issue. The Alt key issue you were having is very unique. If you ever plan on installing Raptr again in the future, and are still running across the issue, you're more than welcome to let us know and we'll do what we can to assist. 

As for the resolution issue, this is an excerpt of what we're getting directly from your dxdiag:

Current Mode: 1360 x 768 (32 bit) (60Hz)
       Monitor Name: Generic PnP Monitor
      Monitor Model: SANYO LCD
         Monitor Id: SAN1207
        Native Mode: 1280 x 720(p) (60.000Hz)


If this is incorrect, you're more than welcome to let us know. Have a great day!

I've used this display for almost 5 years without anything ever trying to set my games to a resolution I can't display, including Geforce Experience. Even Windows first boots into 1360x768. I don't have to go find another display to get out of 1280x720 when I reinstall. If I try to set my desktop resolution to 1280x720 it goes black and I have to wait for it to auto revert. You don't see the frustration involved in that when your software sets my entire library to this resolution and then wont turn it back?

I can understand the frustration. I'm merely stating that as of right now, the Optimization links your monitor's native resolution. In your case, your monitor's native resolution (not current resolution) is 1280x720. I believe we have plans in the future to have more options for resolution when it comes to optimization.

He is not the only one, it took a LONG while for me to figure out what was going on....But when I play Battlefront and press s to back step it just takes screenshots as if ALT is prema pressed down. This is the only game it does it in too..........

I'd recommend changing the hotkey in the meantime. I'll have QA take a look at this issue though. Thanks for letting us know.

Login to post a comment